This incident has been resolved. All affected systems are now operational.
Posted Nov 13, 2025 - 15:13 EST
Monitoring
A fix has been implemented, and systems are recovering. We’re continuing to monitor to ensure system stability.
Posted Nov 13, 2025 - 14:07 EST
Identified
We’ve identified the cause of the issue affecting the processing of Intake form submissions and overall slowness within flows Our team is implementing a fix now. Next update to follow in approximately 60 minutes.