Delayed Processing Speeds

Incident Report for Ziflow

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 11:12 EST

Monitoring

A fix has been implemented and systems are recovering.
We’re continuing to monitor to ensure system stability.
Posted Feb 27, 2026 - 10:42 EST

Investigating

We are currently investigating reports of degraded processing performance within the platform.

Some users may experience slower loading times for Proofs. Our engineering team is currently triaging the cause to restore full functionality.
Posted Feb 27, 2026 - 10:19 EST
This incident affected: Proof Processing.