Intake forms not processing

Incident Report for Ziflow

Resolved

This incident has been resolved.
All affected systems are now operational.
Posted Nov 07, 2025 - 17:13 EST

Investigating

We are currently investigating reports of Intake forms not processing.
We’ll provide an update within 30 minutes or sooner as more information becomes available.
Posted Nov 07, 2025 - 16:57 EST
This incident affected: Zibots.