Web application is not responding
Incident Report for Ziflow
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 18:35 EST
Investigating
We are currently investigating this issue.
Posted Mar 09, 2021 - 18:31 EST
This incident affected: Dashboard.